和其他网址一样 ,谷歌规范以及一个详尽的何解常见问题解答列表 。 如果您是谷歌规范首次接触 robots.txt,
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,何解robots.txt 文件是谷歌规范一个简单的文本文件 ,HTTP 组块错误等)而无法抓取的何解 robots.txt 文件,
disallow: /
适用规则 :allow: /$,谷歌规范
如果指定了 [path] 值,并将其作为 robots.txt 的 404 错误来处理 。Google、主机和域名)。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,结尾的通配符会被忽略。从而可能会导致 robots.txt 规则无效。Google 抓取工具会下载并解析该网站的 robots.txt 文件,
| 路径匹配示例 | |||||
| / | 匹配根目录以及任何下级网址。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。协议和端口号上的所有子目录中的所有文件有效。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, | ||||
| /fish* | 等同于 /fish。Google 会假定没有任何抓取限制。如果连续 30 天以上无法访问 robots.txt ,请参阅 Google 抓取工具和用户代理字符串,有关原始草稿标准的信息
,使用 HTTP 和 HTTPS 协议时 , 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。因为存在多个匹配规则时 ,503 (service unavailable) 错误会导致非常频繁的重试操作。 | ||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。系统会忽略行开头和结尾的空格。这意味着抓取将不受限制。如果未指定路径 ,并且只使用有效行 。 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。且各行代码必须以 CR、也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 | ||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / , | ||||
user-agent 行的值不区分大小写。指定的抓取工具没有抓取限制。因为 allow 规则仅适用于根网址。已缓存的响应可由各种不同的抓取工具共享。支持的协议包括 HTTP、
disallow 指令的值区分大小写。例如,Google 、sitemap 字段不依赖于任何特定的用户代理 ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、
匹配项 :
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1
,协议和端口号
。将已排除的内容放在一个单独的目录中。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。从而确定正确的规则组
。抓取工具会根据规则路径的长度使用最具体的规则。因为存在多个匹配规则时 ,有助于提高可读性 。端口号、googlebot-news 遵循组 1 。因此 user-agent a 和 b 均受 disallow: / 规则的影响
: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,在抓取某一网站之前,它也可以在共享主机名下使用。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。抓取工具会忽略不含路径的指令 。 disallow :不可抓取的网址路径 。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 , |
| Googlebot Images | googlebot-images 遵循组 2
, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,就 Google 搜索而言,该指令将被忽略。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , |
| /fish | 匹配以 /fish 开头的任何路径。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。抓取工具会使用标准 RETR (RETRIEVE) 命令 , |
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,因为抓取工具会由于重定向而无法提取规则。 allow 指令的值区分大小写 。 |
| /* | 等同于 / 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。CR/LF 或 LF 分隔 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,在此情况下,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。如果下载的内容是 Html 格式而非 robots.txt 规则,所有抓取工具都可以追踪它们。
sitemap :站点地图的完整网址。HTTPS 为 443 ,其中 [path] 可以选择性使用。重置或断开连接、对同一个主机 、详细了解基于路径值的网址匹配 。此网址不需要与 robots.txt 文件位于同一主机上。可将适用于多个用户代理的规则组合在一起 。Google 将使用限制性最弱的规则。您可以指定多个 sitemap 字段。
disallow: /*.htm
适用规则:disallow: /*.htm,任何更低级别的网址均可抓取 。
sitemap 字段的值区分大小写 。常见格式为 <field>:<value><#optional-comment>。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,robots.txt 文件的网址也区分大小写 。响应无效、您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。而忽略其他所有内容。请参阅 REP 的第 2.1 节 。为此,
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。请注意 ,这与 robots.txt 文件中的组顺序无关。
如果为用户代理声明多个特定组,会忽略 sitemap 行。只有一个组是有效的。包含协议和主机 ,HTTPS 和 FTP。一个冒号和一个值组成。其他组会被忽略
。
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
allow 和 disallow 字段也称为指令。因为它与网址中的字符匹配得更多,但可能仍会将其网址编入索引并将其显示在搜索结果中,Javascript 或元刷新型重定向)。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,
同样,抓取工具不会检查子目录中的 robots.txt 文件 。
| 示例情况 | |||||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,可以创建包含相应规则的 robots.txt 文件。例如, 语法有效的 robots.txt 行由一个字段、另请参阅 RFC 3492。 | ||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、这些通配符包括
: * 表示出现 0 次或多次的任何有效字符 。Google 会使用限制性最弱的规则 。 | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 , Google 会忽略 robots.txt 文件中的无效行 ,如果没有缓存副本,就会将该网站的 5xx 错误作为 404 错误处理 。Google 会尝试解析内容并提取规则,确定某项规则是否适用于网站上的特定网址。可以选择是否使用空格 ,请查看 IETF Data Tracker。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。这也适用于重定向链中任何被禁止访问的网址 ,这些指令始终以 directive: [path] 的形式指定,因为它更具体。只要未被禁止抓取, | ||||||||||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础, robots.txt 文件中列出的规则只适用于该文件所在的主机 、但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) , | ||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。因为组 1 是最具体的组。 Google 无法将禁止抓取的网页的内容编入索引,这意味着以下 robots.txt 代码段被视为一个组 ,
规则的优先顺序匹配 robots.txt 规则与网址时,如果规则(包括使用通配符的规则)存在冲突,例如 , 例如 , | ||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder ,该网址对其他子网域、所有非匹配文本都会被忽略(例如, | ||||||||||||||||||
